[solved] Problems running TOR on Ubuntu 14.04

5 months ago

Hello everybody, my name is Xenia, I used TOR for several years, but at the moment I am facing with a little problem.
I don't know if this is the correct section for ask (if not, I apologize :oops: )

I ran TOR for more or less 4 years using Ubuntu 10.04. It was very easy, I had just to download the latest version from the TOR website, then unzip the package and click on "start tor browser".

Now I switched to Ubuntu 14.04 and I did as I was used in the past, but in the moment I click on "start tor browser", instead of the usual TOR browser, a text document is open: Ubuntu 14.04 thinks that this link is a text document, and behaving in consequence.

I had a quick look on the web and I found on the Ubuntu forum how to install TOR from terminal. Other sources on the web confirmed the procedure, so I did it.
Now I can run TOR, but it is an old version. The slogan "HOWEVER, this browser is out of date" welcomes me every time. That's quite strange because the second command on the line is actually for updating the stuff.
If my system is only able to run an old version of TOR, it will slowly but inexorably became less and less safe...

Do you have any suggestion? Maybe it is just something of very easy but... may you help me?
Thank-you very much in advance.

5 months ago

I solved the problem.

Ubuntu 14.04 is set for open shell scripts automatically with gedit or another editor.
What to do is very simple: with the administrator rights you have to open the file with gedit, then from the menu select Edit > Preferences > Behaviour for executable text files and then set to ask what to do.
Like this, when you click on the shell script Ubuntu will ask of you want to open or to run it... answering to run, TOR will open.

I am posting this because maybe someone else is in trouble and my solution coold help him/her.


You are not logged in. Login or register to reply on this thread.