Hidden service not reachable

last year

I'm trying to set up a hidden service on a Debian machine.

When setting up the first time all went according to instructions but then the hidden service suddenly stopped responding and I couldn't get it back online. Purged and re-installed Tor and tried again and it worked for a while again. The hidden service seems to go down when restarting Tor. But once I re-installed Tor and did not touch it and the hidden service it kept working for almost 24 hours before inexplicably getting unreachable again.

I'm quite stuck here and could need some help. I'm not a Linux native and suspect I'm doing some silly mistake somewhere, I just don't know where.

last year

Does apache (or nginx) still work? What happens when you try to access http server directly, via localhost?

Can you still see /usr/bin/tor in processlist after hidden service went offline?

last year

Thanks for your reply.

Apache works fine from localhost. Also, I've checked and rechecked the listening directives in Apache conf files and I'm pretty certain there's no errors there.

Tor is visible as 1 process in process list (using ps -e command, I don't know if that's the correct command to use) both before and after hidden service disappears.


You are not logged in. Login or register to reply on this thread.