What's going wrong with Tor v0.2.5.8-rc embedded with vidali


2 years ago
What's going wrong with Tor v0.2.5.8-rc embedded with vidalia v0.2.21?

I started a new non-exit relay 'TORqueue 64C5E87A73C8B5FE0FE02DFB51D83BEC24131EC7' on Windows XP, using Tor v0.2.5.8-rc (from TBB v4.0) embedded with vidalia v0.2.21.



Because I am behind a router (UPnP enabled), I forwarded ORport 443 and DIRport 9030.
I have firewall permissions for ports 80 TCP, 443 TCP/UDP, 9030 TCP/UDP, 9050 TCP/UDP and 9151 TCP - tor.exe is pointed also to the Windows firewall.
vidalia shows my relay is connected and online for at least 12 hours, but 'TORqueue' relay is not show in vidalia's tor network map - atlas and consensus show also my relay is offline.







Oct 22 02:37:55.656 [Notice] Tor v0.2.5.8-rc (git-cc2477cc002ac542) running on Windows XP with Libevent 2.0.21-stable, OpenSSL 1.0.1i and Zlib 1.2.8.
Oct 22 02:37:55.656 [Notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Oct 22 02:37:55.656 [Notice] Read configuration file "...\Data\Tor\torrc".
Oct 22 02:37:55.765 [Notice] Based on detected system memory, MaxMemInQueues is set to 2048 MB. You can override this by setting MaxMemInQueues by hand.
Oct 22 02:37:55.765 [Notice] Opening Socks listener on 127.0.0.1:9050
Oct 22 02:37:55.765 [Notice] Opening Control listener on 127.0.0.1:9151
Oct 22 02:37:55.765 [Notice] Opening OR listener on 0.0.0.0:443
Oct 22 02:37:55.765 [Notice] Opening Directory listener on 0.0.0.0:9030
Oct 22 02:37:55.984 [Notice] Parsing GEOIP IPv4 file ...\Data\Tor\geoip.
Oct 22 02:38:08.343 [Notice] Parsing GEOIP IPv6 file ...\Data\Tor\geoip6.
Oct 22 02:38:08.343 [Notice] Your Tor server's identity key fingerprint is 'TORqueue 64C5E87A73C8B5FE0FE02DFB51D83BEC24131EC7'
Oct 22 02:38:08.343 [Notice] Bootstrapped 0%: Starting
Oct 22 02:38:08.343 [Notice] We now have enough directory information to build circuits.
Oct 22 02:38:08.343 [Notice] Bootstrapped 80%: Connecting to the Tor network
Oct 22 02:38:08.343 [Notice] New control connection opened from 127.0.0.1.
Oct 22 02:38:08.343 [Notice] New control connection opened from 127.0.0.1.
Oct 22 02:38:08.343 [Notice] New control connection opened from 127.0.0.1.
Oct 22 02:38:08.343 [Notice] Guessed our IP address as 109.103.57.102 (source: 208.83.223.34).
Oct 22 02:38:08.343 [Notice] Bootstrapped 85%: Finishing handshake with first hop
Oct 22 02:38:08.343 [Notice] Bootstrapped 90%: Establishing a Tor circuit
Oct 22 02:38:08.812 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Oct 22 02:38:08.812 [Notice] Bootstrapped 100%: Done
Oct 22 02:38:08.812 [Notice] Now checking whether ORPort 109.103.57.102:443 and DirPort 109.103.57.102:9030 are reachable... (this may take up to 20 minutes -- look for log messages indicating success)
Oct 22 02:38:09.609 [Notice] Self-testing indicates your DirPort is reachable from the outside. Excellent.
Oct 22 02:38:10.171 [Notice] Self-testing indicates your ORPort is reachable from the outside. Excellent. Publishing server descriptor.
Oct 22 02:38:13.359 [Notice] Performing bandwidth self-test...done.

This info is also repeated indefinitely

Oct 22 02:41:11.000 [Info] resolve_my_address(): Guessed local hostname 'ophchsso-5ade13' resolves to a private IP address (192.168.100.2). Trying something else.
Oct 22 02:41:11.000 [Info] resolve_my_address(): Interface IP address '192.168.100.2' is a private address too. Ignoring.
Oct 22 02:41:11.000 [Info] resolve_my_address(): Address 'ophchsso-5ade13' resolves to private IP address '192.168.100.2'. Tor servers that use the default DirAuthorities must have public IP addresses.
Oct 22 02:41:11.000 [Info] router_pick_published_address(): Could not determine our address locally. Checking if directory headers provide any hints.
Oct 22 02:41:11.000 [Info] router_pick_published_address(): Success: chose address '109.103.57.102'.


When I exit from vidalia and the relay is closed on my PC, atlas and consensus show my relay is online. I don't understand what is going wrong here.

The previous version TBB v3.6.6 worked fine with vidalia v0.2.21 and my old non-exit relay worked as I expected.

Any suggestion to fix this?

Reply

You are not logged in. Login or register to reply on this thread.